package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i){#val#}|([!-\/:-@[-`{-~])`)
var str = `Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!`
var substitution = ".{0,5}"
fmt.Println(re.ReplaceAllString(str, substitution))
}