$re = '/{#val#}|([!-\/:-@[-`{-~])/i';
$str = 'Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!';
$subst = ".{0,5}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;