#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i){#val#}|([!-\/:-@[-`{-~])"
Local $sString = "Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!"
Local $sSubst = ".{0,5}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)