// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i){#val#}|([!-\/:-@[-`{-~])").unwrap();
let string = "Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!";
let substitution = ".{0,5}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}