import re
regex = re.compile(r"{#val#}|([!-\/:-@[-`{-~])", flags=re.IGNORECASE)
test_str = "Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!"
subst = ".{0,5}"
result = regex.sub(subst, test_str)
if result:
print(result)