# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\\/P>/$1$2/gmi;t' <<< "<td>
<P CLASS=\"abc\">
hello</P>
</td>
<P CLASS=\"abc\">
hello</P>
"