#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>"
Local $sString = "<td>" & @CRLF & _
"<P CLASS="abc">" & @CRLF & _
"hello</P>" & @CRLF & _
"</td>" & @CRLF & _
"<P CLASS="abc">" & @CRLF & _
"hello</P>" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)