// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>").unwrap();
let string = "<td>
<P CLASS=\"abc\">
hello</P>
</td>
<P CLASS=\"abc\">
hello</P>
";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}