const regex = /(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<td>[\\s\\S]*?)<P[^>]*>[\\n\\t\\r]*([^>]+)<\\\/P>', 'gmi')
const str = `<td>
<P CLASS="abc">
hello</P>
</td>
<P CLASS="abc">
hello</P>
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);