import re
regex = re.compile(r"(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("<td>\n"
"<P CLASS=\"abc\">\n"
"hello</P>\n"
"</td>\n"
"<P CLASS=\"abc\">\n"
"hello</P>\n")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)