package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>`)
var str = `<td>
<P CLASS="abc">
hello</P>
</td>
<P CLASS="abc">
hello</P>
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}