re = /(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>/mi
str = '<td>
<P CLASS="abc">
hello</P>
</td>
<P CLASS="abc">
hello</P>
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result