import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<td>[\\s\\S]*?)<P[^>]*>[\\n\\t\\r]*([^>]+)<\\/P>";
final String string = "<td>\n"
+ "<P CLASS=\"abc\">\n"
+ "hello</P>\n"
+ "</td>\n"
+ "<P CLASS=\"abc\">\n"
+ "hello</P>\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}