use strict;
my $str = '<td>
<P CLASS="abc">
hello</P>
</td>
<P CLASS="abc">
hello</P>
';
my $regex = qr/(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>/mip;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";