import Foundation
let pattern = #"(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<td>
<P CLASS="abc">
hello</P>
</td>
<P CLASS="abc">
hello</P>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)