using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<td>[\s\S]*?)<P[^>]*>[\n\t\r]*([^>]+)<\/P>";
string substitution = @"$1$2";
string input = @"<td>
<P CLASS=""abc"">
hello</P>
</td>
<P CLASS=""abc"">
hello</P>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}