# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$/$1 $2/gmi;t' <<< "john@learn.edu
john@mypost.com
invalid
john@gmail.com
john@dblist.org"