import Foundation
let pattern = #"^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
john@learn.edu
john@mypost.com
invalid
john@gmail.com
john@dblist.org
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)