const regex = /^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w([^@\\s,;]+)@(mypost\\.com|[\\w-]+\\.edu)$', 'gmi')
const str = `john@learn.edu
john@mypost.com
invalid
john@gmail.com
john@dblist.org`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);