re = /^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$/mi
str = 'john@learn.edu
john@mypost.com
invalid
john@gmail.com
john@dblist.org'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result