import re
regex = re.compile(r"^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("john@learn.edu\n"
"john@mypost.com\n"
"invalid\n"
"john@gmail.com\n"
"john@dblist.org")
subst = "$1 $2"
result = regex.sub(subst, test_str)
if result:
print(result)