import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w([^@\\s,;]+)@(mypost\\.com|[\\w-]+\\.edu)$";
final String string = "john@learn.edu\n"
+ "john@mypost.com\n"
+ "invalid\n"
+ "john@gmail.com\n"
+ "john@dblist.org";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}