package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$`)
var str = `john@learn.edu
john@mypost.com
invalid
john@gmail.com
john@dblist.org`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}