use strict;
my $str = 'john@learn.edu
john@mypost.com
invalid
john@gmail.com
john@dblist.org';
my $regex = qr/^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$/mip;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";