$re = '/^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$/mi';
$str = 'john@learn.edu
john@mypost.com
invalid
john@gmail.com
john@dblist.org';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;