#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$"
Local $sString = "john@learn.edu" & @CRLF & _
"john@mypost.com" & @CRLF & _
"invalid" & @CRLF & _
"john@gmail.com" & @CRLF & _
"john@dblist.org"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)