// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$").unwrap();
let string = "john@learn.edu
john@mypost.com
invalid
john@gmail.com
john@dblist.org";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}