using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w([^@\s,;]+)@(mypost\.com|[\w-]+\.edu)$";
string substitution = @"$1 $2";
string input = @"john@learn.edu
john@mypost.com
invalid
john@gmail.com
john@dblist.org";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}