#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\w)(nin)\b"
Local $sString = "yilanin" & @CRLF & _
"suyunin" & @CRLF & _
"kalinin" & @CRLF & _
"batinin" & @CRLF & _
"kinindan" & @CRLF & _
"sininteki" & @CRLF & _
"nin" & @CRLF & _
"ninkisi" & @CRLF & _
"xxxnin" & @CRLF & _
"xxxninxxx" & @CRLF & _
"nin"
Local $sSubst = "$1NG"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)