// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w)(nin)\b").unwrap();
let string = "yilanin
suyunin
kalinin
batinin
kinindan
sininteki
nin
ninkisi
xxxnin
xxxninxxx
nin";
let substitution = "$1NG";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}