using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w)(nin)\b";
string substitution = @"$1NG";
string input = @"yilanin
suyunin
kalinin
batinin
kinindan
sininteki
nin
ninkisi
xxxnin
xxxninxxx
nin";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}