$re = '/(\w)(nin)\b/';
$str = 'yilanin
suyunin
kalinin
batinin
kinindan
sininteki
nin
ninkisi
xxxnin
xxxninxxx
nin';
$subst = "$1NG";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;