const regex = /(\w)(nin)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w)(nin)\\b', 'g')
const str = `yilanin
suyunin
kalinin
batinin
kinindan
sininteki
nin
ninkisi
xxxnin
xxxninxxx
nin`;
const subst = `$1NG`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);