use strict;
my $str = 'yilanin
suyunin
kalinin
batinin
kinindan
sininteki
nin
ninkisi
xxxnin
xxxninxxx
nin';
my $regex = qr/(\w)(nin)\b/p;
my $subst = '$1NG';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";