import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w)(nin)\\b";
final String string = "yilanin\n"
+ "suyunin\n"
+ "kalinin\n"
+ "batinin\n"
+ "kinindan\n"
+ "sininteki\n"
+ "nin\n"
+ "ninkisi\n"
+ "xxxnin\n"
+ "xxxninxxx\n"
+ "nin";
final String subst = "$1NG";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}