import Foundation
let pattern = #"(\w)(nin)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
yilanin
suyunin
kalinin
batinin
kinindan
sininteki
nin
ninkisi
xxxnin
xxxninxxx
nin
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1NG"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)