re = /(\w)(nin)\b/
str = 'yilanin
suyunin
kalinin
batinin
kinindan
sininteki
nin
ninkisi
xxxnin
xxxninxxx
nin'
subst = '$1NG'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result