# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/declare\s+@([^\s]+)\s+(?:as\s+)?table/CREATE TABLE #$1/gmi;t' <<< "
declare @myTable as table
(
id int
)
declare @myTable1 table
(
id int
)"