using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"declare\s+@([^\s]+)\s+(?:as\s+)?table";
string substitution = @"CREATE TABLE #$1";
string input = @"
declare @myTable as table
(
id int
)
declare @myTable1 table
(
id int
)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}