re = /declare\s+@([^\s]+)\s+(?:as\s+)?table/mi
str = '
declare @myTable as table
(
id int
)
declare @myTable1 table
(
id int
)'
subst = 'CREATE TABLE #$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result