package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)declare\s+@([^\s]+)\s+(?:as\s+)?table`)
var str = `
declare @myTable as table
(
id int
)
declare @myTable1 table
(
id int
)`
var substitution = "CREATE TABLE #$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}