import Foundation
let pattern = #"declare\s+@([^\s]+)\s+(?:as\s+)?table"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
declare @myTable as table
(
id int
)
declare @myTable1 table
(
id int
)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"CREATE TABLE #$1"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)