$re = '/declare\s+@([^\s]+)\s+(?:as\s+)?table/mi';
$str = '
declare @myTable as table
(
id int
)
declare @myTable1 table
(
id int
)';
$subst = "CREATE TABLE #$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;