const regex = /declare\s+@([^\s]+)\s+(?:as\s+)?table/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('declare\\s+@([^\\s]+)\\s+(?:as\\s+)?table', 'gmi')
const str = `
declare @myTable as table
(
id int
)
declare @myTable1 table
(
id int
)`;
const subst = `CREATE TABLE #$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);