import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "declare\\s+@([^\\s]+)\\s+(?:as\\s+)?table";
final String string = "\n\n\n"
+ "declare @myTable as table\n"
+ "(\n"
+ " id int \n"
+ ")\n\n"
+ "declare @myTable1 table\n"
+ "(\n"
+ " id int \n"
+ ")";
final String subst = "CREATE TABLE #$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}