import re
regex = re.compile(r"declare\s+@([^\s]+)\s+(?:as\s+)?table", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\n\n\n"
"declare @myTable as table\n"
"(\n"
" id int \n"
")\n\n"
"declare @myTable1 table\n"
"(\n"
" id int \n"
")")
subst = "CREATE TABLE #$1"
result = regex.sub(subst, test_str)
if result:
print(result)