using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[url=([^][\s]+)](.*?)\[/url]";
string substitution = @"<a href='$1' target='_blank'>$2</a>";
string input = @"[url=https://test.com]my link[/url]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}