import re
regex = re.compile(r"\[url=([^][\s]+)](.*?)\[/url]")
test_str = "[url=https://test.com]my link[/url]"
subst = "<a href='$1' target='_blank'>$2</a>"
result = regex.sub(subst, test_str)
if result:
print(result)