re = /\[url=([^][\s]+)](.*?)\[\/url]/
str = '[url=https://test.com]my link[/url]'
subst = '<a href=\'$1\' target=\'_blank\'>$2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result