use strict;
my $str = '[url=https://test.com]my link[/url]';
my $regex = qr~\[url=([^][\s]+)](.*?)\[/url]~p;
my $subst = '<a href=\'$1\' target=\'_blank\'>$2</a>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";